Feature #102

Compile for 64bit

Added by jbk almost 7 years ago. Updated almost 7 years ago.

Status:ClosedStart date:11/14/2010
Priority:NormalDue date:
Assignee:jbk% Done:

100%

Category:ClientEstimated time:46.00 hours
Target version:v0.3s - Sunflower

Description

Glue
Blender

glue - example binary for win64 (6.04 MB) jbk, 11/14/2010 16:18

glue - example binary for win32 (4.81 MB) jbk, 11/14/2010 17:28

glue - example binary for linux32 (1.27 MB) jbk, 11/20/2010 10:04

linux2.tar.gz (22.4 MB) jbk, 12/03/2010 14:54

linux32_linux2.tar.gz - Linux 32bit (21.1 MB) jbk, 12/03/2010 18:02

win32.zip - win32 blender client (15.5 MB) jbk, 12/04/2010 19:24

win64.zip - win64 blender client (12.6 MB) jbk, 12/04/2010 19:27

glue - 64bit linux (1.47 MB) jbk, 12/05/2010 13:10

History

#1 Updated by jbk almost 7 years ago

Testing out a unified build environment capable of producing binaries for both Windows64/32 and Linux64/32

#2 Updated by jbk almost 7 years ago

#3 Updated by jbk almost 7 years ago

#4 Updated by jbk almost 7 years ago

#5 Updated by jbk almost 7 years ago

  • File glue added
  • % Done changed from 10 to 20

#6 Updated by jbk almost 7 years ago

blender win64:
  • __int64 => long long
  • extern/glew/include/GL/glew.h at typedef unsigned short wchar_t - add defined(_WIN64) ||
    ///-D_GLIBCXX_USE_WCHAR_T
    //* -D_GLIBC_USE_WCHAR_T
  • linuxcross: lib dir from windows to win64
  • python 3.1
  • ranlib on build/lib/*.a
  • edit ftgl -> ../windows/ftgl and openexr -> ../windows/openexr
  • have to put the following inside winbuildinfo.h
    (which you create, in source/creator):
    char * build_date=BUILD_DATE;
    char * build_time=BUILD_TIME;
    char * build_platform=BUILD_PLATFORM;
    char * build_type=BUILD_TYPE;
    

#7 Updated by jbk almost 7 years ago

  • % Done changed from 20 to 30

Linking fails... bigtime... Will have to switch to Windows to actually get it to compile for now.

Things left:
  • Clean up linux Blender compiles
  • Compile the release candidates for 32bit and 64bit linux
  • Compile for 32bit and 64bit windows on windows

#8 Updated by jbk almost 7 years ago

  • File blender_linux2_x86-64-2010-12-03.tar.gz added

A 64bit linux Blender release candidate is available.

#9 Updated by jbk almost 7 years ago

  • File deleted (blender_linux2_x86-64-2010-12-03.tar.gz)

#10 Updated by jbk almost 7 years ago

  • File blender_linux2_x86-64-2010-12-03.tar.gz added

#11 Updated by jbk almost 7 years ago

  • File ld-2.12.1.so added

#12 Updated by jbk almost 7 years ago

#13 Updated by jbk almost 7 years ago

  • File deleted (ld-2.12.1.so)

#14 Updated by jbk almost 7 years ago

  • File deleted (blender_linux2_x86-64-2010-12-03.tar.gz)

#15 Updated by jbk almost 7 years ago

32bit linux client VM is up and running and an example Blender release candidate is now available.
Also, here's the stuff needed to setup a new compile node on Ubuntu:

sudo apt-get install mc yasm scons subversion gettext build-essential g++ libx11-dev libgl1-mesa-dev libxi-dev zlib1g-dev libpng12-dev libglu1-mesa-dev libjpeg62-dev libfreetype6-dev libtiff4-dev libopenexr-dev libsdl1.2-dev libopenal-dev python2.6-dev libfftw3-dev libsamplerate0-dev libjack-dev libavformat-dev libogg-dev libfaac-dev libfaad-dev libx264-dev libmp3lame-dev libvorbis-dev libtheora-dev libswscale-dev libavdevice-dev 
svn checkout http://development.burp.renderfarming.net/svn/repos/burp
cd checkout/compilefarm
setup.sh
cd renderers/blender
scons

#16 Updated by jbk almost 7 years ago

On windows 7:
1) Get visual studio 2008 express
2) Get Windows SDK for Windows 7
3) Install sliksvn
4) Run update.bat to compile for 32bit

zzZZzzZZzZZZ

5) Rename c:\Program Files (x86)\Microsoft Visual Studio 9.0\VC\vcpackages\AMD64.VCPlatform.Config to AMD64.VCPlatform.Express.Config
6) Copy c:\Program Files (x86)\Microsoft Visual Studio 9.0\VC\bin\vcvars64.bat to .\amd64\vcvarsamd64.bat
7) Export [HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\VisualStudio\9.0\VC\VC_OBJECTS_PLATFORM_INFO]::Win64 (AMD64) REGEDIT4/NT4 format, replace all "VisualStudio" with "VCExpress" and re-import back into registry
8) Do the same for [HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\VisualStudio\9.0\CLSID]::{656d8763-2429-11d7-8bf6-00b0d03daa06}
9) And [HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\VisualStudio\9.0\CLSID]::{656d8760-2429-11d7-8bf6-00b0d03daa06}
10) And [HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\VisualStudio\9.0\CLSID]::{656d875f-2429-11d7-8bf6-00b0d03daa06}
11) Windows 7 SDK CMD shell: CD setup<enter> WindowsSdkVer.exe -version:v7.0<enter>
12) Make a shortcut for the new 64bit shell: comspec /k c:\Program Files (x86)\Microsoft Visual Studio 9.0\VC\vcvarsall.bat" amd64
13) Edit config/win32-vc: libdir + IX86 => x64
14) Wave with magic wand in a couple of hours while throwing tricks of the trade and fixing broken stuff
15) Now run update.bat to compile for 64bit (only the scons line)

#17 Updated by jbk almost 7 years ago

  • File win32.zip added
  • % Done changed from 30 to 60

A win32 version of the Blender release candidate is now available

#18 Updated by jbk almost 7 years ago

  • File win64.zip added
  • % Done changed from 60 to 70

A win64 version of the Blender release candidate is now available.

Things still to do:
  • Clean up the linux archives (need make sure it works with Glue)
  • Clean up the windows archives (need to add/remove extra .dlls)

#19 Updated by jbk almost 7 years ago

  • File deleted (glue)

#20 Updated by jbk almost 7 years ago

glue should have preloader support on linux

#21 Updated by jbk almost 7 years ago

  • Estimated time changed from 36.00 to 46.00

It seems the 64bit Blender for Windows is crashing.

#22 Updated by jbk almost 7 years ago

  • Status changed from New to Resolved
  • % Done changed from 70 to 100

Applied in changeset r1234.

#23 Updated by jbk almost 7 years ago

  • Status changed from Resolved to Closed

The crash was caused by the tempdir code recently introduced - Windows needs a full path rather than just a relative path.

Also available in: Atom PDF